Customers hosted with logic.bm
Incident Report for One Communications
Resolved
Resolved.
Posted 10 months ago. Dec 04, 2017 - 12:35 AST
Monitoring
The issue has been identified and resolved. Please be advised that mail may be delayed as our server processes the email queue.
Posted 10 months ago. Nov 24, 2017 - 10:52 AST
Investigating
Please be advised that we are currently experiencing an outage with customers using logic hosted email. Engineers are currently investigating. Updates will be provided as they are made available.
Posted 10 months ago. Nov 24, 2017 - 10:32 AST