One Comm Long Distance - One Plus and 2020220
Incident Report for One Communications
Resolved
Engineers have resolved the issue impacting the long distance services. If you continue to have an issue, please contact the One Communications for further assistance.
Posted about 1 month ago. Apr 16, 2018 - 12:48 ADT
Investigating
Engineers are currently investigating an issue impacting all One Plus and 2020220 long distance customers. An update will be provided within the next 30 minutes.
Posted about 1 month ago. Apr 16, 2018 - 12:18 ADT