Email Response time
Incident Report for One Communications
Resolved
This issue has been resolved. Response time for mail is back down to normal.
Posted over 1 year ago. Jul 07, 2017 - 14:39 ADT
Investigating
We are investigating an issue with our email systems. Customers might experience slow response browsing email through the web browser, or sporadic disconnections on their email clients. This issue will not affect customers using the .logic.bm domain.
Posted over 1 year ago. Jul 07, 2017 - 07:34 ADT