Logic Email/Webmail
Incident Report for One Communications
Resolved
Please be advised the issue impacting Logic Email/Webmail has been resolved
Posted Feb 22, 2019 - 11:40 AST
Investigating
Please be advised engineers are currently investigating an issue impacting Logic email customers and access to webmail.
Posted Feb 22, 2019 - 11:25 AST
This incident affected: E-mail.