Emergency Demand Maintenance by BTC
Incident Report for One Communications
Resolved
All customers appear to be back online and BTC has finished maintenance as of 5am, February 22th, 2018.
Posted about 1 year ago. Feb 22, 2018 - 11:31 AST
Monitoring
BTC will be performing Demand Maintenance that will affect all BTC access and broadband customers. Affected time period: 02/22/18 - 1am - 5am
Posted about 1 year ago. Feb 19, 2018 - 17:21 AST