Top Level DNS Issue
Incident Report for One Communications
Resolved
The issue with One Communications's DNS domains has been resolved. However, some other customer's DNS domains might still not be working. The owners of those domains are advised to contact BermudaNIC directly to resolve their domains. Their website is https://www.bermudanic.bm/.

If One Communications customers still not get to domains such as logic.bm or northrock.bm, they are advised to please reboot their router and computer.
Posted almost 2 years ago. Jan 07, 2017 - 12:02 AST
Identified
One Communications is aware of an issue with some DNS domains ending with .bm (example, logic.bm or northrock.bm). While One Communication's DNS servers are functioning correctly, many .bm domains are showing as expired. We are working with the authority responsible with the .bm domains to resolve the issue as quickly as possible.

Customers may experience issues accessing sites and servers ending with .bm, including www.logic.bm, mail.logic.bm, www.northrock.bm, mail.northrock.bm, etc.
Posted almost 2 years ago. Jan 07, 2017 - 07:42 AST