Emergency Demand Maintenance by BTC
Incident Report for One Communications
Resolved
Resolved
Posted 3 months ago. Feb 22, 2018 - 11:30 AST
Monitoring
BTC will be performing Demand Maintenance that will affect all BTC access and broadband customers. Affected time period: 02/20/18 - 1AM - 5am
Posted 3 months ago. Feb 19, 2018 - 16:32 AST