Belco Power Outage
Incident Report for One Communications
Resolved
If you are still experiencing connectivity issues, please contact our help desk at 700-7000 for further assistance.
Posted Sep 04, 2019 - 14:17 ADT
Monitoring
Belco is working on a permanent fix. Customers will continue to experience intermittent power.
Posted Sep 04, 2019 - 11:06 ADT
This incident affected: Internet, TV, Access, and Phone.