ISP with BTC Access and Long Distance customers
Incident Report for One Communications
Resolved
This incident has been resolved.
Posted Jan 08, 2019 - 13:09 AST
Monitoring
Engineers have resolved the issue impacting long distance and ISP customer with BTC access. If you are unable to connect please contact the Help Desk at (441) 700-7000
Posted Nov 02, 2018 - 12:37 ADT
Investigating
Engineers are currently working toward resolving an issue affecting our ISP and Long Distance customers with BTC Access. If you are offline, we kindly ask that you wait for our instruction before rebooting your service. Updates will be provided to keep you informed of our progress.

Thank you.
Posted Nov 02, 2018 - 11:34 ADT
This incident affected: Internet, Access, and Long Distance.