*** Email outage affecting former North Rock accounts ***
Incident Report for One Communications
Resolved
Please be advised the issue has been rectified, and we thank you for your patience during this time.
Posted about 1 year ago. Jun 28, 2017 - 16:39 ADT
Update
Engineers are currently still investigating this issue. there is no available ETA at this time.
Posted about 1 year ago. Jun 28, 2017 - 16:14 ADT
Update
Please be advised we are currently investigating an issue that is impacting ALL email customers
Posted about 1 year ago. Jun 28, 2017 - 15:24 ADT
Investigating
Please be advised we are currently investigating an issue that is impacting all former North Rock email customers.
Posted about 1 year ago. Jun 28, 2017 - 15:16 ADT